注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

红尘若梦

生活的色彩

 
 
 

日志

 
 

Android项目提示requires compiler compliance level 5.0 or 6.0. Found '1.7' instead.  

2015-11-16 11:56:50|  分类: 技术 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
在引入一些已经存在的项目时,经常会报一个提示:Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties,该信息出现原因是因为项目创建时所使用的JDK跟你目前使用的JDK版本不同,所以在明白以上之后,修复也很简单。
修复方法:
1)项目右键 ->android tools->Fix Project
Android项目提示requires compiler compliance level 5.0 or 6.0. Found 1.7 instead. - 1976xyg - 红尘若梦
2)检查Project->Properties->Java Compiler,确认Compiler compliance level被设置为1.6,并且enable specific seetings.
Android项目提示requires compiler compliance level 5.0 or 6.0. Found 1.7 instead. - 1976xyg - 红尘若梦
说明下,Compiler compliance level被设置为1.6,只是让编译器相信你的代码是兼容较低版本的,在编译时生成的bytecode(class)会兼容较低版本,与当前时引用的JDK版本是没关系的,也就是说在新写代码时仍可以引用较高版本的API.(这样就可能导致运行时错误)却设置compiler compliance level为较低版本,这样的好处是当别人使用了较低版本的Jdk时也可以引用您写的编译后的代码包,保证编译后的class文件的版本一致性。但是,请记住有得必有失,如果代码里面(java source)里面调用了较高版本jdk的API,那么即使设置了compiler compliance level为较低版本,在较低版本的JDK上运行您写的代码还是会报错。
所以再次强调下,在写代码时引用的JDK版本,最好跟compiler compliance level设置的版本,是一致。不然会造成很多麻烦和错误。
  评论这张
 
阅读(124)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017